Старые приложения могут работать плохо в Android P

Добавлено — 19.03.2018

В очередном превью Android P для разработчиков обнаружена функция, проверяющая версию API, с помощью которого написаны приложения для мобильных устройств. Минимальная указанная версия — 17, что соответствует Android 4.2 Jelly Bean. Если приложение написано на более раннем API, всплывающее предупреждение сообщит о возможных проблемах в работе ПО.

Так Google пытается заставить разработчиков использовать более актуальные версии API и гарантировать пользователям их поддержку в современных смартфонах. Впрочем, с учетом темпов распространения новых версий Android, такой подход эффективен лишь отчасти.

По данным Google за февраль, наиболее актуальная версия — Android 8 Oreo — установлена на 1,1% мобильных устройств, Nougat — на 28,5%, Marshmallow — 28,1%.




+ В закладки
  • Отзывы
  • Личный опыт
  • Статьи
25.06.2019 — NewSwat
Samsung Galaxy A9 (2018) - Телефоны
Я считаю что Galaxy A9 - это телефон практически премиального класса. Изготовлен из качественных материалов, выглядит очень стильн...
23.06.2019 — Наталья
Samsung Galaxy A10 - Телефоны
Вот уже 4-ре дня я с этим смартфоном и если бы было можно его вернуть и забрать деньги, то сделала бы это не задумываясь - он висн...
Еще?

TOP-модели
Samsung Galaxy A70
Samsung Galaxy M40
Samsung Galaxy Fit e
Samsung Galaxy A50



Войти через:
Впервые на Samsung Club? Зарегистрируйтесь или воспользуйтесь формой логина.